Please configure

Spark app update

From 24 May 2017, you won't be able to get into the old Spark smartphone app. If you're seeing an error message when you open the old smartphone app, you'll need to update your app.

  • If you're seeing the error message above, you're using the old smartphone app that we no longer support.
  • To use the new Spark mobile app, you'll need to update your current app.
  • You can also select Update now on the error message to download the new Spark app.

  • If you're seeing the error message above, you'll need to delete the app and download the new Spark mobile app.
  • The new Spark app is available on iOS 8, 9 and 10, and on Android 4, 5 and 6.
Was this article helpful for you?
Thanks for your feedback.
Thanks for your feedback.